SIMPLE
Sign in to saveAlso known as session initiation protocol for instant messaging and presence leveraging extensions
computer instant messaging protocol
Article · Русский
SIMPLE (Session Initiation Protocol for Instant Messaging and Presence Leveraging Extensions) — набор профилей и расширений стандарта SIP, предназначенных для систем мгновенной передачи сообщений (IM) и уведомления о присутствии (Presence). Как и XMPP, SIMPLE, в отличие от подавляющего числа существующих протоколов для передачи мгновенных сообщений и уведомления о присутствии, является открытым стандартом. Также одной из важных особенностей протокола является возможность использования списков присутствия (presence lists), взятых из других приложений. В SIMPLE SIP применяется для: * отправки коротких сообщений, аналогичных SMS; * установления сеанса обмена мгновенными сообщениями в реальном времени для двоих и более участников списка присутствия; * для обновления статуса присутствия участников списка присутствия. В 2006 году IETF поручил рабочей группе под названием SIMPLE Working Group определить набор профилей и расширений стандарта SIP, предназначенных для системы мгновенной передачи сообщений и уведомления о присутствии. В документах RFC: RFC 2778 Архивная копия от 8 августа 2007 на Wayback Machine и RFC 2779 Архивная копия от 7 августа 2007 на Wayback Machine, RFC 3428 Архивная копия от 6 августа 2007 на Wayback Machine группа определила модель её функционирования и основные требования к системе мгновенной передачи сообщений и уведомления о присутствии. Ключевые компоненты протокола уже успели получить достаточно широкое распространение, наиболее известен Microsoft Windows Messenger Архивная копия от 11 декабря 2007 на Wayback Machine. SIMPLE – не единственный IM-протокол, разработанный внутри IETF. Например, таковым является XMPP.
Abstract from DBpedia / Wikipedia · CC BY-SA